记录生活
简单不先于复杂

WordPress PHP 版本要求、MySQL 版本要求及 Apache 或 Nginx 版本要求

和其他 PHP 程序一样,WordPress 对 PHP 版本和 MySQL 版本是有要求的,WordPress 对 PHP 和 MySQL 版本的要求主要分为核心 PHP 版本要求、主题 PHP 版本要求和插件 PHP 版本要求。

WordPress 核心的 PHP 和 MySQL 版本需求

根据 WordPress 的官方主机环境要求说明,WordPress 建议主机环境符合以下要求:

  • PHP 7.3 或更高版本
  • MySQL 5. 6 或更高版本,MariaDB 10.0 或更高版本
  • HTTPS 支持

Apache 或者 Nginx 是运行 WordPress 最健壮和功能最丰富的服务器,但是使用其他支持 PHP 或 MySQL 的 Web 服务器也是可以的。

WordPress主题的 PHP 和 MySQL 版本需求

WordPress主题的开发者成千上万,各个主题对 PHP 版本的需求也都不一样,WordPress 目前没有提供判断主题 PHP 版本需求的方法。有些主题会把 PHP 版本需求写在 readme.txt 文件中,我们可以试着在这个文件里面寻找。如果找不到,可以在主题开发者提供的支持论坛中向主题开发者提问。

WordPress插件 的 PHP 和 MySQL 版本要求

和主题不同,WordPress 已经在官方插件目录中直接列出了插件的 PHP 版本需求,我们可以直接在插件介绍页面右侧的插件元信息中查看,如下图:

220d571c05747f8e4414cf03e57e626f
WordPress插件 PHP 版本需求

有些插件为了防止 PHP 版本不能满足需求而带来的致命错误,会在插件激活时,判断服务器的 PHP 版本以确定是否激活插件功能。

关于主题和插件对 MySQL 版本的需求,目前并没有比较直接的判断方法,不过相对于 PHP,MySQL 版本之间的区别并不是太大,不至于版本不满足需求就直接出现致命错误而导致网站不能运行。

怎么确定主题提供的 PHP 和 MySQL 版本

直接咨询主题提供商

如果您不确定您的 Web 服务器提供的 PHP 和 MySQL 版本,WordPress 提供了一个简单的问题帮助您向服务器提供商提问来弄清楚这个问题。你可以直接复制下面的内容给您的服务器提供商进行咨询。

我需要在我们的服务器上运行最新版本的 WordPress,我想知道我的服务器是否支持以下内容。

1、PHP 7.3 或更高版本
2、MySQL 5. 6 或更高版本,MariaDB 10.0 或更高版本
3、HTTPS 支持
4、Nginx 或带有 mod_rewrite 模块的 Apache 以支持 Url Rewrite 功能

在 phpMyAdmin 中查看

如果您的主题提供了 phpMyAdmin 功能,我们还可以在 phpMyAdmin 中查看 PHP 和 MySQL 版本信息,在 phpMyAdmin 的后台主页,找到如下界面即可查看。

b5d21bfebe36fbf51081c7384c392456

及时更新 PHP 和 MySQL 或 MariaDB 办否

虽然较低的 PHP 或 MySQL 版本也能够运行 WordPress、但是为了安全起见,建议有条件的朋友及时升级到最新的版本、同时、新的版本还会带来功能的增强和性能方面的提升。如果担心最新版本有 Bug,可以升级到上一个稳定版本、并及时关注 PHP 或 MySQL 版本的支持信息。

  • PHP 版本支持信息
  • MySQL 和 MariaDB 版本支持信息
赞(0)
未经允许不得转载:爱安普 » WordPress PHP 版本要求、MySQL 版本要求及 Apache 或 Nginx 版本要求